CompassLearning Odyssey
Privacy PolicySystem RequirementsCompassLearning.comContact Us
 
Home PageCompassLearning Odyssey SolutionsEducatorsCustomer Support
image51
 
Sample Activities
Universal Access Code


Verify that this workstation meets our system requirements.

Check System for required software.

  Minimum Hardware Requirements
Windows® P4 (or AMD equiv.) 256 MB RAM 30 MB hard drive space
800x600 pixel resolution,
256 Color depth,
14" color monitor
16-bit sound card, speakers, headphones.
Microphone required for ELL
128 Kbps ISDN/IDSL Internet connection1 Color printer, faster CPU, more RAM, larger monitor, faster Internet connection
 
Macintosh® G3 or Intel  256 MB RAM 30 MB hard drive space
800x600 pixel resolution,
256 Color depth,
14" color monitor
16-bit sound card, speakers/
headphones
128 Kbps ISDN/IDSL Internet connection1 Color printer, faster CPU, more RAM, larger monitor, faster Internet connection
1. Performance and activity loading time varies with speed of Internet connection.

  Supported Software Environments
Windows® Macintosh®
Windows XP Professional or Home
Windows Vista
Mac OS 10.3.4 or 10.4
 
Internet Explorer (Win) 6.0 or 7.0

Get Microsoft Internet Explorer


Netscape® 8.1 or 8.21

Firefox 1.5 or 2.0.0.4
Safari 2.0.4

Netscape® 7.22

Firefox 1.5 or 2.0.0.4
 
Macromedia FlashT Player 8.0 or 9.0

Get Macromedia Flash Player


Adobe Acrobat Reader® 7.0 or 8.0

Apple QuickTime® Player 7.03

PrintOMaticT XtraT Plugin3

Macromedia Shockwave® Player 10.03,4
Get Macromedia Shockwave Player

Sun Java Virtual Machine 1.4.2 or 1.55


Microsoft Agent6

Microsoft Agent Download Button

Macromedia FlashT Player 8.0 or 9.0

Get Macromedia Flash Player


Adobe Acrobat Reader® 7.0 or 8.0

Apple QuickTime® Player 7.03

PrintOMaticT XtraT Plugin3

Macromedia Shockwave® Player 10.03,4
Get Macromedia Shockwave Player

Sun Java Virtual Machine 1.4.2 or 1.55

  1. Netscape 8.0 must be configured for Odyssey. For instructions, see the Odyssey User's Guide, Chapter 1, "Configuring Netscape 8.0."
  2. Netscape 7.2 for Mac OS 10.3.4 - 10.3.9 includes Sun Java Virtual machine 1.3.x. For ELL Secondary, this must be upgraded to Sun Java Virtual machine 1.4.2, using the Java Embedding plug-in for Mac OS X.
  3. Required for PreK activities.
  4. Required for ELL Elementary and Algebra.
  5. Required for ELL Secondary.
  6. Optional for HTML activities.